#71 Spam folder from gmail not listed

Closed
opened 7 months ago by oblitum · 8 comments
oblitum commented 7 months ago

This spam folder is listed in log, but it's not displayed in UI.

I have other gmail-based accounts (from G Suite, with custom domain) and they have the spam folder listed, and in status tab it's set as special Junk folder. The same isn't happening for this other pure gmail account.

#imap

This spam folder is [listed in log](https://gist.github.com/oblitum/67bb8e4e553b4698bf358a69dbeac741), but it's not displayed in UI. I have other gmail-based accounts (from G Suite, with custom domain) and they have the spam folder listed, and in status tab it's set as special Junk folder. The same isn't happening for this other pure gmail account. \#imap
epilys commented 7 months ago
Poster
Owner

I'm gonna need some help with this, what is the LIST response?

I'm gonna need some help with this, what is the `LIST` response?
oblitum commented 7 months ago
Poster
[2020-09-20 18:03:59]["meli-executor-7"] melib/src/backends/imap.rs:1386_9: out: * LIST (\HasNoChildren) "/" "INBOX"
* STATUS "INBOX" (MESSAGES 74628 UNSEEN 0)
* LIST (\HasChildren \NonExistent) "/" "[Gmail]"
* LIST (\HasNoChildren) "/" "[Gmail]/Com estrela"
* STATUS "[Gmail]/Com estrela" (MESSAGES 30 UNSEEN 0)
* LIST (\HasNoChildren) "/" "[Gmail]/E-mails enviados"
* STATUS "[Gmail]/E-mails enviados" (MESSAGES 2805 UNSEEN 0)
* LIST (\HasNoChildren) "/" "[Gmail]/Lixeira"
* STATUS "[Gmail]/Lixeira" (MESSAGES 0 UNSEEN 0)
* LIST (\HasNoChildren) "/" "[Gmail]/Rascunhos"
* STATUS "[Gmail]/Rascunhos" (MESSAGES 1 UNSEEN 0)
* LIST (\HasNoChildren) "/" "[Gmail]/Spam"
* STATUS "[Gmail]/Spam" (MESSAGES 52 UNSEEN 52)
M5 OK Success
``` [2020-09-20 18:03:59]["meli-executor-7"] melib/src/backends/imap.rs:1386_9: out: * LIST (\HasNoChildren) "/" "INBOX" * STATUS "INBOX" (MESSAGES 74628 UNSEEN 0) * LIST (\HasChildren \NonExistent) "/" "[Gmail]" * LIST (\HasNoChildren) "/" "[Gmail]/Com estrela" * STATUS "[Gmail]/Com estrela" (MESSAGES 30 UNSEEN 0) * LIST (\HasNoChildren) "/" "[Gmail]/E-mails enviados" * STATUS "[Gmail]/E-mails enviados" (MESSAGES 2805 UNSEEN 0) * LIST (\HasNoChildren) "/" "[Gmail]/Lixeira" * STATUS "[Gmail]/Lixeira" (MESSAGES 0 UNSEEN 0) * LIST (\HasNoChildren) "/" "[Gmail]/Rascunhos" * STATUS "[Gmail]/Rascunhos" (MESSAGES 1 UNSEEN 0) * LIST (\HasNoChildren) "/" "[Gmail]/Spam" * STATUS "[Gmail]/Spam" (MESSAGES 52 UNSEEN 52) M5 OK Success ```
epilys commented 7 months ago
Poster
Owner

Can you provide a complete session log just for this account (start meli till imap connects, then exit)? You can email it to me since it's sensitive data.

Can you provide a complete session log just for this account (start meli till imap connects, then exit)? You can email it to me since it's sensitive data.
epilys commented 7 months ago
Poster
Owner

Ok, so the spam folder is missing from the LSUB reply. That's probably it then. Was the LSUB reply in the original post from another server?

Ok, so the spam folder is missing from the LSUB reply. That's probably it then. Was the LSUB reply in the original post from another server?
oblitum commented 7 months ago
Poster

Not sure about the question. All I can say is that the entire log was generated with just one single account set up, the problematic one, and I sent the log to you through that account too.

Not sure about the question. All I can say is that the entire log was generated with just one single account set up, the problematic one, and I sent the log to you through that account too.
oblitum commented 7 months ago
Poster

FWIW, one strange thing happened. The mail has the trace.log of ~5MB. After sending, I tried to open the email in meli, then when I tried to take a look at the 5MB text attachment by typing <number>a, meli hanged and the memory usage went up to 9GB until I force killed it.

FWIW, one strange thing happened. The mail has the trace.log of ~5MB. After sending, I tried to open the email in meli, then when I tried to take a look at the 5MB text attachment by typing `<number>a`, meli hanged and the memory usage went up to 9GB until I force killed it.
epilys commented 7 months ago
Poster
Owner

Not sure about the question. All I can say is that the entire log was generated with just one single account set up, the problematic one, and I sent the log to you through that account too.

In the log the Spam folder is not subscribed (hence why it doesn't show up). This problem turns up a lot, I'll try to do something about this!

FWIW, one strange thing happened. The mail has the trace.log of ~5MB. After sending, I tried to open the email in meli, then when I tried to take a look at the 5MB text attachment by typing a, meli hanged and the memory usage went up to 9GB until I force killed it.

Got that error as well, and found out the cause 👍 there was gratuitous allocation dependent on the text width. The log file had some long lines.

> Not sure about the question. All I can say is that the entire log was generated with just one single account set up, the problematic one, and I sent the log to you through that account too. In the log the Spam folder is not subscribed (hence why it doesn't show up). This problem turns up a lot, I'll try to do something about this! > FWIW, one strange thing happened. The mail has the trace.log of ~5MB. After sending, I tried to open the email in meli, then when I tried to take a look at the 5MB text attachment by typing <number>a, meli hanged and the memory usage went up to 9GB until I force killed it. Got that error as well, and found out the cause 👍 there was gratuitous allocation dependent on the text width. The log file had some long lines.
epilys commented 5 months ago
Poster
Owner

Closing in favour of #73

Closing in favour of https://git.meli.delivery/meli/meli/issues/73
epilys closed this issue 5 months ago
Sign in to join this conversation.
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.