#101 Meli runs but times out on launch

Open
opened 1 month ago by flber · 0 comments
flber commented 1 month ago

After going through the gmail imap setup (creating a client and secret id for a new application, and setting imap to true in gmail), I filled out the meli config file as follows (with private values filled in):

[accounts."imap"]
root_mailbox = "INBOX"
format = "imap"
server_hostname="imap.gmail.com"
use_oath2 = true
server_password_command="TOKEN=$(python3 /home/user/oauth2.py --user=user@gmail.com --quiet --client_id=someid.apps.googleusercontent.com --client_secret=somesecret --refresh_token=thetokengeneratedfromoauth2py) && python3 oauth2.py --user=user@gmail.com --generate_oauth2_string --quiet --access_token=$TOKEN"
server_username="user@gmail.com"
server_port="993" # imaps
server_port="587" # STARTTLS
use_starttls="true" #optional
index_style = "Conversations"
identity = "user@gmail.com"
display_name = "user"
## match every mailbox:
subscribed_mailboxes = ["*" ]

When I run meli with this configuration it doesn't fail, but says offline: Attempting connection. which then turns to offline: Timed out. after a short time.

Considering it says it's offline (when my computer is definitely not), I feel like this is probably an error on my part, so any help or clarification would be very appreciated.

After going through the gmail imap setup (creating a client and secret id for a new application, and setting imap to true in gmail), I filled out the meli config file as follows (with private values filled in): ``` [accounts."imap"] root_mailbox = "INBOX" format = "imap" server_hostname="imap.gmail.com" use_oath2 = true server_password_command="TOKEN=$(python3 /home/user/oauth2.py --user=user@gmail.com --quiet --client_id=someid.apps.googleusercontent.com --client_secret=somesecret --refresh_token=thetokengeneratedfromoauth2py) && python3 oauth2.py --user=user@gmail.com --generate_oauth2_string --quiet --access_token=$TOKEN" server_username="user@gmail.com" server_port="993" # imaps server_port="587" # STARTTLS use_starttls="true" #optional index_style = "Conversations" identity = "user@gmail.com" display_name = "user" ## match every mailbox: subscribed_mailboxes = ["*" ] ``` When I run meli with this configuration it doesn't fail, but says `offline: Attempting connection.` which then turns to `offline: Timed out.` after a short time. Considering it says it's offline (when my computer is definitely not), I feel like this is probably an error on my part, so any help or clarification would be very appreciated.
Sign in to join this conversation.
No Milestone
No project
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.