Browse Source

Update smallvec dependency to 1.5.0

Fixes panicking when loading cached serialized email from older versions
of meli.

https://github.com/servo/rust-smallvec/pull/238
master
Manos Pitsidianakis 1 week ago
parent
commit
5b86c342fb
Signed by: epilys GPG Key ID: 73627C2F690DF710
3 changed files with 4 additions and 4 deletions
  1. +2
    -2
      Cargo.lock
  2. +1
    -1
      Cargo.toml
  3. +1
    -1
      melib/Cargo.toml

+ 2
- 2
Cargo.lock View File

@ -1760,9 +1760,9 @@ dependencies = [
[[package]]
name = "smallvec"
version = "1.4.2"
version = "1.5.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "fbee7696b84bbf3d89a1c2eccff0850e3047ed46bfcd2e92c29a2d074d57e252"
checksum = "7acad6f34eb9e8a259d3283d1e8c1d34d7415943d4895f65cc73813c7396fc85"
dependencies = [
"serde",
]

+ 1
- 1
Cargo.toml View File

@ -45,7 +45,7 @@ bincode = "^1.3.0"
uuid = { version = "0.8.1", features = ["serde", "v4"] }
unicode-segmentation = "1.2.1" # >:c
libc = {version = "0.2.59", features = ["extra_traits",]}
smallvec = { version = "^1.4.0", features = ["serde", ] }
smallvec = { version = "^1.5.0", features = ["serde", ] }
bitflags = "1.0"
pcre2 = { version = "0.2.3", optional = true }
structopt = { version = "0.3.14", default-features = false }

+ 1
- 1
melib/Cargo.toml View File

@ -37,7 +37,7 @@ unicode-segmentation = { version = "1.2.1", optional = true }
libc = {version = "0.2.59", features = ["extra_traits",]}
isahc = { version = "0.9.7", optional = true, default-features = false, features = ["http2", "json", "text-decoding"]}
serde_json = { version = "1.0", optional = true, features = ["raw_value",] }
smallvec = { version = "^1.4.0", features = ["serde", ] }
smallvec = { version = "^1.5.0", features = ["serde", ] }
nix = "0.17.0"
rusqlite = {version = "0.24.0", optional = true }

Loading…
Cancel
Save